Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

placement_classification_table broken?

Hi Lucas,

I apologize in advance for bothering you again so quickly. I am trying to use the placement_classification_table app with genesis-0.11.0 and it gets stuck. I've tried rebuilding it but that hasn't helped. Here's what I'm getting:

[congxu@lg-1r17-n04 epa]$ placement_classification_table RAxML_portableTree.papara_alignment.16s_torrey.raxmlEPAout.jplace 16s_torrey_papara_table.txt
INFO Using jplace file RAxML_portableTree.papara_alignment.16s_torrey.raxmlEPAout.jplace
INFO Using output file 16s_torrey_papara_table.txt
INFO Found 57 placements.

Nothing happens afterwards and when I force quit, the output file is created but with nothing in it. Thanks for your help!

Comments

  • Hi Charles,

    don't worry, ask as many questions as you need until stuff is working. Otherwise, my programs would be pretty useless, wouldn't they?!

    Well, from the distance, it is hard to judge what is going on there. How big is the jplace file, particularly, how many tips does the tree have, and how many query sequences are placed? How long did you wait? The program does some calculations that might take some minutes.

    If you want, you can email me the input file and I'll check. lucas.czech@h-its.org

    Best
    Lucas
  • Hi Lucas,

    The longest I've waited was maybe 15-20 min. The jplace files I am working with now are not very big, less than 200 kb. As I pasted above, there's only 57 placements so it shouldn't be taking this long...
  • I've also tried with multiple jplace files and nothing is working so the problem isn't file specific.
  • Hm okay, no idea what's going on there. Can you please email one of those files to me?
  • Ah okay, thanks, got the file. The issue was the following: I did not pay too much attention to efficiency in the placement_classification_table app, so for each placement, a distance measure on the whole tree was calculated.

    That was easy to fix. See here: https://gist.github.com/lczech/24c12a912e4eb0ed38d517d887c42db5
    On my machine, it runs in 30sec now.
  • Also, if you are still needing the "Compare Jplace Files" demo program, please update to genesis v0.11.1: https://github.com/lczech/genesis/releases/tag/v0.11.1

    I recently found a bug in the demo that can lead to some wrong entries in the second table.
  • Hi Lucas,

    Awesome. You are fantastic. Keep up the good work!
  • Hi Charles,

    there was yet another small issue with the Earth Mover's Distance
    values in the "Compare Jplace Files" demo program. If you are using
    those values, please update to Genesis v0.12.1. Sorry for the
    inconvenience, I really should check my demo programs more...

    Cheers

    Lucas

  • Hi Lucas,

    Will do. Thanks for the update.
Sign In or Register to comment.